Search The ForumSearch   RegisterRegister  LoginLogin

AfterLogic WebMail Lite

 AfterLogic Forum : AfterLogic WebMail Lite
Subject Topic: Password change for ISPConfig 3 Post ReplyPost New Topic
Author
Message << Prev Topic | Next Topic >>
oazis
Newbie
Newbie


Joined: 26 March 2022
Location: Ukraine
Online Status: Offline
Posts: 6
Posted: 27 March 2022 at 4:56am | IP Logged Quote oazis

Hi there everyone!

Help solve the problem. Installed ISPConfig 3.2.8 on Debian 11 (Bullseye), wanted to use as a mail service "Afterlogic WebMail Lite PHP"-version.9.3.1. According to the instructions set up a module that allows users to change passwords for their email accounts in ISPConfig https://afterlogic.com/docs/webmail-pro-8/configuring-webmail/password-change-for-ispconfig

However, when connecting, it gives an error <The username or password you entered is incorrect.> Please tell me how to fix the error?

Code:
[10:36:45.80>[c4a41d65> [POST(4)>[ip:194.28.182.67> /afterlogic/?/Api/
[10:36:45.80>[c4a41d65> POST > [Module, Method, Parameters, TenantName>
[10:36:45.80>[c4a41d65>
[10:36:45.80>[c4a41d65> Exception: ApiException

[11:00:12.15>[ba3f6491> [POST(4)>[ip:194.28.182.67> /afterlogic/?/Api/
[11:00:12.15>[ba3f6491> POST > [Module, Method, Parameters, TenantName>
[11:00:12.15>[ba3f6491>
[11:00:12.15>[ba3f6491> Exception: ApiException

[11:15:38.55>[a93454a3> [POST(4)>[ip:194.28.182.67> /afterlogic/?/Api/
[11:15:38.55>[a93454a3> POST > [Module, Method, Parameters, TenantName>
[11:15:38.55>[a93454a3>
[11:15:38.55>[a93454a3> Exception: ApiException

[11:15:50.75>[d0fd5b7e> [POST(4)>[ip:194.28.182.67> /afterlogic/?/Api/
[11:15:50.75>[d0fd5b7e> POST > [Module, Method, Parameters, TenantName>
[11:15:50.75>[d0fd5b7e>
[11:15:50.75>[d0fd5b7e> Exception: ApiException

[11:46:54.40>[53007725> [POST(4)>[ip:194.28.182.67> /afterlogic/?/Api/
[11:46:54.40>[53007725> POST > [Module, Method, Parameters, TenantName>
[11:46:54.40>[53007725>
[11:46:54.40>[53007725> Exception: ApiException


Thanks for your time!
Back to Top View oazis's Profile Search for other posts by oazis
 
Igor
AfterLogic Support
AfterLogic Support


Joined: 24 June 2008
Location: United States
Online Status: Offline
Posts: 5886
Posted: 28 March 2022 at 12:11am | IP Logged Quote Igor

Hello,

The critical part of setting this module up is to configure the database access correctly. In data/settings/modules/MailChangePasswordIspconfigPlugin.config.json configuration file, you need to specify database connection details - these won't be database details of WebMail itself, but details of ISPConfig database.

If you still encounter issues, set LogStackTrace to true in data/settings/config.json file, that way you'll have detailed stack trace instead of ApiException message - bear in mind that sensitive information such as passwords may be shown there.

--
Regards,
Igor, Afterlogic Support
Back to Top View Igor's Profile Search for other posts by Igor
 
oazis
Newbie
Newbie


Joined: 26 March 2022
Location: Ukraine
Online Status: Offline
Posts: 6
Posted: 28 March 2022 at 5:43am | IP Logged Quote oazis

Igor wrote:
If you still encounter issues, set LogStackTrace to true in data/settings/config.json file, that way you'll have detailed stack trace instead of ApiException message - bear in mind that sensitive information such as passwords may be shown there.


Thanks for your help, but I also can't connect to the database 'dbispconfig'. Made the settings according to the above instructions, provided ROOT access and password to the database - <data/settings/modules/MailChangePasswordIspconfigPlugin.config.json>. Enabled displaying additional information:

Code:
[12:28:21.40>[5f98441d> [POST(4)>[ip:194.28.182.67> /afterlogic/?/Api/
[12:28:21.40>[5f98441d> POST > [Module, Method, Parameters, TenantName>
[12:28:21.40>[5f98441d>
[12:28:21.40>[5f98441d> Aurora\System\Exceptions\ApiException: ApiException in /usr/share/afterlogic/modules/Core/Module.php:2149
Stack trace:
#0 [internal function>: Aurora\Modules\Core\Module->SetAuthDataAndGetAuthToken()
#1 /usr/share/afterlogic/system/Module/AbstractModule.php(836): call_user_func_array()
#2 /usr/share/afterlogic/system/Module/Decorator.php(55): Aurora\System\Module\AbstractModule->CallMethod()
#3 /usr/share/afterlogic/modules/Core/Module.php(2225): Aurora\System\Module\Decorator->__call()
#4 [internal function>: Aurora\Modules\Core\Module->Login()
#5 /usr/share/afterlogic/system/Module/AbstractModule.php(836): call_user_func_array()
#6 /usr/share/afterlogic/system/Module/Decorator.php(55): Aurora\System\Module\AbstractModule->CallMethod()
#7 /usr/share/afterlogic/modules/StandardLoginFormWebclient/Module.php(47): Aurora\System\Module\Decorator->__call()
#8 [internal function>: Aurora\Modules\StandardLoginFormWebclient\Module->Login()
#9 /usr/share/afterlogic/system/Module/AbstractModule.php(836): call_user_func_array()
#10 /usr/share/afterlogic/modules/Core/Module.php(666): Aurora\System\Module\AbstractModule->CallMethod()
#11 [internal function>: Aurora\Modules\Core\Module->EntryApi()
#12 /usr/share/afterlogic/system/Router.php(111): call_user_func_array()
#13 /usr/share/afterlogic/system/Module/Manager.php(639): Aurora\System\Router->route()
#14 /usr/share/afterlogic/system/Application.php(141): Aurora\System\Module\Manager->RunEntry()
#15 /usr/share/afterlogic/system/Application.php(110): Aurora\System\Application->Route()
#16 /usr/share/afterlogic/index.php(21): Aurora\System\Application::Start()
#17 {main}


What does not allow you to connect to the database of email addresses ?
Back to Top View oazis's Profile Search for other posts by oazis
 
Igor
AfterLogic Support
AfterLogic Support


Joined: 24 June 2008
Location: United States
Online Status: Offline
Posts: 5886
Posted: 28 March 2022 at 5:51am | IP Logged Quote Igor

Not entirely sure where this log is coming from. Do you get the error when trying to log into an email account, or when trying to change email account password?

--
Regards,
Igor, Afterlogic Support
Back to Top View Igor's Profile Search for other posts by Igor
 
oazis
Newbie
Newbie


Joined: 26 March 2022
Location: Ukraine
Online Status: Offline
Posts: 6
Posted: 28 March 2022 at 7:02am | IP Logged Quote oazis

Igor wrote:
Not entirely sure where this log is coming from. Do you get the error when trying to log into an email account, or when trying to change email account password?

I am getting an error when I try to login with an email account that is in ISPConfig 3. After all, the mail service 'Afterlogic' should work in conjunction, do I understand correctly?
Back to Top View oazis's Profile Search for other posts by oazis
 
Igor
AfterLogic Support
AfterLogic Support


Joined: 24 June 2008
Location: United States
Online Status: Offline
Posts: 5886
Posted: 28 March 2022 at 7:08am | IP Logged Quote Igor

OK I see. You've asked the question about password change method, I assumed that's where you get an error. My guess is, something's wrong with mail server settings in WebMail admin interface. Try deleting all the mail servers you have there, add just one, with empty list of Domains, make sure IMAP/SMTP server settings point to 127.0.0.1 or localhost, and see if that helps.

--
Regards,
Igor, Afterlogic Support
Back to Top View Igor's Profile Search for other posts by Igor
 
oazis
Newbie
Newbie


Joined: 26 March 2022
Location: Ukraine
Online Status: Offline
Posts: 6
Posted: 28 March 2022 at 7:17am | IP Logged Quote oazis

I repeat my problem. On a virtual machine under Debian 11, I installed hosting panel ISPConfig 3.2.8, after installation, according to the instructions <https://afterlogic.com/docs/webmail-lite/installation/installing-on-debian-ubuntu-linux>, configured 'AfterLogic WebMail Lite' and set up module 'Password change for ISPConfig' <https://afterlogic.com/docs/webmail-pro-8/configuring-webmail/password-change-for-ispconfig>.
However, mail accounts that are created ISPConfig 3, not used in 'AfterLogic WebMail Lite', when connecting, it gives an error <The username or password you entered is incorrect.>
Back to Top View oazis's Profile Search for other posts by oazis
 
Igor
AfterLogic Support
AfterLogic Support


Joined: 24 June 2008
Location: United States
Online Status: Offline
Posts: 5886
Posted: 28 March 2022 at 7:23am | IP Logged Quote Igor

Does the situation differ if you don't install a password change module? I mean, are you certain that it's related to the issue you've encountered?

Also, did you actually add an entry under "Mail Servers" in adminpanel of WebMail Lite? Without that, logging in would not work, as WebMail has no idea what mailserver you want it to connect to.

--
Regards,
Igor, Afterlogic Support
Back to Top View Igor's Profile Search for other posts by Igor
 
oazis
Newbie
Newbie


Joined: 26 March 2022
Location: Ukraine
Online Status: Offline
Posts: 6
Posted: 28 March 2022 at 7:39am | IP Logged Quote oazis

Igor wrote:
Also, did you actually add an entry under "Mail Servers" in adminpanel of WebMail Lite? Without that, logging in would not work, as WebMail has no idea what mailserver you want it to connect to.

Thanks for the tip, I didn't specify under "Mail Servers" in adminpanel of WebMail Lite. After that everything worked!

Another question, is it possible to transfer the database of letters from the old server via SSH connection?
Back to Top View oazis's Profile Search for other posts by oazis
 
Igor
AfterLogic Support
AfterLogic Support


Joined: 24 June 2008
Location: United States
Online Status: Offline
Posts: 5886
Posted: 28 March 2022 at 7:45am | IP Logged Quote Igor

Glad that worked! As for the 2nd question, WebMail itself doesn't store mails in the database, it accesses those on mail server via IMAP directly. So if you wish to transfer mails from a different server, it's best to use mailserver-level migration tools for this purpose.

That being said, WebMail allows for exporting mails from a folder as ZIP archive, and you can also import ZIP with mail messages so they will be uploaded onto specific folder of an account on mail server:

Export and import mails saved as ZIP archive

--
Regards,
Igor, Afterlogic Support
Back to Top View Igor's Profile Search for other posts by Igor
 
oazis
Newbie
Newbie


Joined: 26 March 2022
Location: Ukraine
Online Status: Offline
Posts: 6
Posted: 28 March 2022 at 7:51am | IP Logged Quote oazis

Dear Igor, thanks for your help!
Back to Top View oazis's Profile Search for other posts by oazis
 

If you wish to post a reply to this topic you must first login
If you are not already registered you must first register

  Post ReplyPost New Topic
Printable version Printable version

Forum Jump

Powered by Web Wiz Forums version 7.9
Copyright ©2001-2004 Web Wiz Guide