Search The ForumSearch   RegisterRegister  LoginLogin

MailBee SMTP

 AfterLogic Forum : MailBee SMTP
Subject Topic: incorrect accented characters in body Post ReplyPost New Topic
Author
Message << Prev Topic | Next Topic >>
Axa
Newbie
Newbie


Joined: 08 November 2019
Online Status: Offline
Posts: 3
Posted: 04 February 2022 at 6:41am | IP Logged Quote Axa

Hi,
i'm using Mailbee Object 9.1 ( active components - default charset UTF-8) and accented characters are displayed correctly in the subject but incorrectly in emailís body (using Outlook):

subject : prova mailbee ž Ť ŗ ý
body: prova mailbee � � � �

More precisely:
- the display is not correct if the .pst file was created by old Outlook versions
- the display is correct if the .pst file was created by a new version of outlook.

If the e-mail is sent with Outlook, subject and body are right.
Furthermore, the structure of the emailís RawMessage sent with MailBee and Outlook is different.

Is there any solution?


Thanks,
Monica
Back to Top View Axa's Profile Search for other posts by Axa
 
Alex
AfterLogic Support
AfterLogic Support
Avatar

Joined: 19 November 2003
Online Status: Offline
Posts: 2163
Posted: 04 February 2022 at 7:00am | IP Logged Quote Alex

Hi,

Both subject and body texts are hardcoded in your test code? Because if, for instance, subject is hardcoded while body is taken from database/client_request/file/etc, data can be damaged before it's passed to MailBee.

You can also open the email in email client other than Outlook. Or send email to another email address where you can check this (e.g. Gmail) and where you can get the raw source of the email. Because this thing with different behavior for different PST versions looks strange and more testing with other mail systems is needed.

Regards,
Alex
Back to Top View Alex's Profile Search for other posts by Alex
 
Axa
Newbie
Newbie


Joined: 08 November 2019
Online Status: Offline
Posts: 3
Posted: 25 February 2022 at 12:55am | IP Logged Quote Axa

Hi,
Both subject and body texts have been inserted manually, no from database.

For the second point, if we open the email from email server, it is correct.
The problem is only with file.PST created by Outlook of old versions (up to 2002).
So we just wanted to understand the different handling between subject and body texts.
Maybe the solution is for our client to update the .PST file.

Thank you very much.
Regards
Monica
Back to Top View Axa's Profile Search for other posts by Axa
 
Alex
AfterLogic Support
AfterLogic Support
Avatar

Joined: 19 November 2003
Online Status: Offline
Posts: 2163
Posted: 25 February 2022 at 4:08am | IP Logged Quote Alex

Hi,

You can save the email into .EML file after sending (like with Message.SaveMessage method) and send it to us for examination, via Helpdesk.

Regards,
Alex
Back to Top View Alex's Profile Search for other posts by Alex
 

If you wish to post a reply to this topic you must first login
If you are not already registered you must first register

  Post ReplyPost New Topic
Printable version Printable version

Forum Jump

Powered by Web Wiz Forums version 7.9
Copyright ©2001-2004 Web Wiz Guide