Search The ForumSearch   RegisterRegister  LoginLogin

AfterLogic WebMail Lite

 AfterLogic Forum : AfterLogic WebMail Lite
Subject Topic: web migration from version 8 Post ReplyPost New Topic
Author
Message << Prev Topic | Next Topic >>
totoetco
Newbie
Newbie


Joined: 11 November 2021
Location: France
Online Status: Offline
Posts: 1
Posted: 11 November 2021 at 3:45am | IP Logged Quote totoetco

Hello,
I am having issues migrating from v8 from web based migration.
Problem looks similar to previous topic but version 9.1.1.build9-build-a3 does not change anything for me.
After running db_init.php, I get
QueryException {#609 ▼
#sql: "create table `au_core_users` (`Id` int unsigned not null auto_increment primary key, `UUID` varchar(255) not null, `Name` varchar(255) not null default '', `PublicId` varchar(255) not null, `IdTenant` int not null default '0', `IsDisabled` tinyint(1) not null default '0', `IdSubscription` int not null default '0', `Role` int not null default '2', `DateCreated` datetime null, `LastLogin` datetime null, `LastLoginNow` varchar(255) not null default '', `LoginsCount` int not null default '0', `Language` varchar(255) not null default '', `TimeFormat` int null default '1', `DateFormat` varchar(255) not null default '', `Question1` varchar(255) not null default '', `Question2` varchar(255) not null default '', `Answer1` varchar(255) not null default '', `Answer2` varchar(255) not null default '', `SipEnable` tinyint(1) not null default '1', `SipImpi` varchar(255) not null default '', `SipPassword` varchar(255) not null default '', `DesktopNotifications` tinyint(1) not null default '0', `Capa` varchar(255) not null default '', `CustomFields` varchar(255) not null default '', `FilesEnable` tinyint(1) not null default '1', `EmailNotification` varchar(255) not null default '', `PasswordResetHash` varchar(255) not null default '', `WriteSeparateLog` tinyint(1) not null default '0', `TokensValidFromTimestamp` int not null default '0', `DefaultTimeZone` varchar(255) not null default '', `Properties` json null, `CreatedAt` timestamp null, `UpdatedAt` timestamp null) default character set utf8 collate 'utf8_general_ci' ◀"
#bindings: []
#message: "SQLSTATE[42000]: Syntax error or access violation: 1064 You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'json null, `CreatedAt` timestamp null, `UpdatedAt` timestamp null) default chara' at line 1 (SQL: create table `au_core_users` (`Id` int unsigned not null auto_increment primary key, `UUID` varchar(255) not null, `Name` varchar(255) not null default '', `PublicId` varchar(255) not null, `IdTenant` int not null default '0', `IsDisabled` tinyint(1) not null default '0', `IdSubscription` int not null default '0', `Role` int not null default '2', `DateCreated` datetime null, `LastLogin` datetime null, `LastLoginNow` varchar(255) not null default '', `LoginsCount` int not null default '0', `Language` varchar(255) not null default '', `TimeFormat` int null default '1', `DateFormat` varchar(255) not null default '', `Question1` varchar(255) not null default '', `Question2` varchar(255) not null default '', `Answer1` varchar(255) not null default '', `Answer2` varchar(255) not null default '', `SipEnable` tinyint(1) not null default '1', `SipImpi` varchar(255) not null default '', `SipPassword` varchar(255) not null default '', `DesktopNotifications` tinyint(1) not null default '0', `Capa` varchar(255) not null default '', `CustomFields` varchar(255) not null default '', `FilesEnable` tinyint(1) not null default '1', `EmailNotification` varchar(255) not null default '', `PasswordResetHash` varchar(255) not null default '', `WriteSeparateLog` tinyint(1) not null default '0', `TokensValidFromTimestamp` int not null default '0', `DefaultTimeZone` varchar(255) not null default '', `Properties` json null, `CreatedAt` timestamp null, `UpdatedAt` timestamp null) default character set utf8 collate 'utf8_general_ci') ◀"
#code: "42000"
#file: "/home/breniereto/cloud/vendor/illuminate/database/Connection.php"
#line: 671
-previous: Exception {#608 ▶}
+errorInfo: array:3 [▶]
trace: {▶}
}
Any ideas ?
Thanks
Back to Top View totoetco's Profile Search for other posts by totoetco
 
Igor
AfterLogic Support
AfterLogic Support


Joined: 24 June 2008
Location: United States
Online Status: Offline
Posts: 5902
Posted: 11 November 2021 at 4:10am | IP Logged Quote Igor

Prior to migrating from v8, can you try installing v9 from scratch, create a new database connection there and see if it works? If database connection is successful, see if you can add a mail server and log into a email account.

Also, be sure to check what MySQL engine you're running. For example:

Code:
/usr/bin/mysql -V


While running compatibility test helps, checking MySQL version may still be important.

--
Regards,
Igor, Afterlogic Support
Back to Top View Igor's Profile Search for other posts by Igor
 

If you wish to post a reply to this topic you must first login
If you are not already registered you must first register

  Post ReplyPost New Topic
Printable version Printable version

Forum Jump

Powered by Web Wiz Forums version 7.9
Copyright ©2001-2004 Web Wiz Guide