Search The ForumSearch   RegisterRegister  LoginLogin

AfterLogic WebMail Lite

 AfterLogic Forum : AfterLogic WebMail Lite
Subject Topic: New error after updating PHP Post ReplyPost New Topic
Author
Message << Prev Topic | Next Topic >>
Gimli
Newbie
Newbie


Joined: 03 March 2018
Location: Canada
Online Status: Offline
Posts: 10
Posted: 15 September 2021 at 8:36am | IP Logged Quote Gimli

So, I'm now on Webmail Lite PHP 9.0.1 and running PHP7.2 successfully (Windows and IIS 10).

I'm trying to update PHP to 8.0 to be within the minimum requirements for Webmail 9 (there is no PHP 7.5 available for Windows) but once I'm running PHP 8.0 a new error pops up:

Code:
Fatal error: Uncaught WebAuthn\WebAuthnException: OpenSSL-Module not installed in C:\WebMailPHP9\modules\TwoFactorAuth\Classes\WebAuthn\WebAuthn.php:50 Stack trace: #0 C:\WebMailPHP9\modules\TwoFactorAuth\Module.php(73): WebAuthn\WebAuthn->__construct('WebAuthn Librar...', 'xxx.xxx.xx', Array, false, Array) #1 C:\WebMailPHP9\system\Module\AbstractModule.php(277): Aurora\Modules\TwoFactorAuth\Module->init() #2 C:\WebMailPHP9\system\Module\Manager.php(304): Aurora\System\Module\AbstractModule->initialize() #3 C:\WebMailPHP9\system\Module\Manager.php(112): Aurora\System\Module\Manager->loadModule('TwoFactorAuth', 'C:\\WebMailPHP9/...') #4 C:\WebMailPHP9\system\Api.php(232): Aurora\System\Module\Manager->loadModules() #5 C:\WebMailPHP9\system\Application.php(99): Aurora\System\Api::Init() #6 C:\WebMailPHP9\index.php(21): Aurora\System\Application::Start() #7 {main} thrown in C:\WebMailPHP9\modules\TwoFactorAuth\Classes\WebAuthn\WebAuthn.php on line 50


Webmail 9 actually works pretty well with PHP 7.2, the only things that don't work are the "Test connection" and "Update tables" in the database configuration page.

Any idea how to fix that new SSL error?
Back to Top View Gimli's Profile Search for other posts by Gimli
 
Igor
AfterLogic Support
AfterLogic Support


Joined: 24 June 2008
Location: United States
Online Status: Offline
Posts: 5903
Posted: 15 September 2021 at 11:25am | IP Logged Quote Igor

There's probably a misunderstanding, WebMail Lite v9 requires PHP 7.2.5 at least - and PHP 7.5 does not exist indeed. Problem with "Test connection" / "Update tables" is probably caused by old MySQL driver used, make sure you use mysqlnd driver - Compatibility Test will confirm if that's the case.

With regard to SSL-related error, make sure you have OpenSSL extension enabled in your PHP environment. You can also try disabling TwoFactorAuth module to work around the error, that's done by setting Disabled to true in data/settings/modules/TwoFactorAuth.config.json configuration file.

--
Regards,
Igor, Afterlogic Support
Back to Top View Igor's Profile Search for other posts by Igor
 
Gimli
Newbie
Newbie


Joined: 03 March 2018
Location: Canada
Online Status: Offline
Posts: 10
Posted: 17 September 2021 at 11:29am | IP Logged Quote Gimli

Thank you for your help Igor!

Turns out I needed to copy over my old php.ini file to the new PHP folder, that fixed the Open-SSL error.

Then I needed to uncomment the ";extension=mysqli" line in it to fix the database settings page in the admin panel. For some reason it appears we need both the mysqli and pdo-mysql extensions enabled.

Couldn't have done it without your pointers, thanks again!
Back to Top View Gimli's Profile Search for other posts by Gimli
 

If you wish to post a reply to this topic you must first login
If you are not already registered you must first register

  Post ReplyPost New Topic
Printable version Printable version

Forum Jump

Powered by Web Wiz Forums version 7.9
Copyright ©2001-2004 Web Wiz Guide