Search The ForumSearch   RegisterRegister  LoginLogin

AfterLogic WebMail Lite

 AfterLogic Forum : AfterLogic WebMail Lite
Subject Topic: cPanel default mail accout Post ReplyPost New Topic
Author
Message << Prev Topic | Next Topic >>
moucho
Newbie
Newbie


Joined: 19 July 2021
Online Status: Offline
Posts: 1
Posted: 19 July 2021 at 2:34am | IP Logged Quote moucho

I have an error on Afterlogic webmail installed on a cPanel/WHM server.

When using the default or "system" email account (cPanel user) with Afterlogic, it throws this error:

Code:
501 : sender address must contain a domain


Exim error:
Code:
unqualified sender rejected: <CPANEL_USER> H=localhost (HOSTNAME) [127.0.0.1]:40926 I=[127.0.0.1]:25


It seems that it is trying to send an email using the user (with no domain) instead of appending the cPanel domain account to the user, as other webmails like Roundcube does.

Can this behavior be configured? Is it a known issue?
Back to Top View moucho's Profile Search for other posts by moucho
 
Igor
AfterLogic Support
AfterLogic Support


Joined: 24 June 2008
Location: United States
Online Status: Offline
Posts: 5681
Posted: 19 July 2021 at 2:59am | IP Logged Quote Igor

The only way for WebMail to determine the domain is to obtain it from email address you are logging in with. If it's not there, it won't work I'm afraid. You can configure mail login form so that domain is appended automatically, but it's not the case for embedded WebMail installation, only when WebMail is installed from a regular ZIP package and its own login form is used.

--
Regards,
Igor, Afterlogic Support
Back to Top View Igor's Profile Search for other posts by Igor
 

If you wish to post a reply to this topic you must first login
If you are not already registered you must first register

  Post ReplyPost New Topic
Printable version Printable version

Forum Jump

Powered by Web Wiz Forums version 7.9
Copyright ©2001-2004 Web Wiz Guide