Search The ForumSearch   RegisterRegister  LoginLogin

MailBee.NET IMAP

 AfterLogic Forum : MailBee.NET IMAP
Subject Topic: UidPlusResult SrcUids & DestUids are NULL Post ReplyPost New Topic
Author
Message << Prev Topic | Next Topic >>
hmuscroft
Groupie
Groupie


Joined: 29 December 2009
Location: United Kingdom
Online Status: Offline
Posts: 72
Posted: 28 January 2017 at 6:37am | IP Logged Quote hmuscroft

Hi,

I'm finding on a number of IMAP servers, the UidPlusResult object ia coming back from a call to "imap.MoveMessages(...)" with "IsSupported = true" but both the SrcUids collection and the DestUids collections are NULL. They're not EMPTY collections, but the actual UidCollection object itself is NULL.

This happens even though the ".MoveMessages(...)" operation has worked correctly and the messages have all been moved. Further, the server's I'm testing with (YAHOO / HOTMAIL / GMAIL / 1&1 IMAP) all report that they support UIDPLUS.

The really odd one is GMAIL's behaviour which *sometimes* works and returns the UID collections and sometimes doesn't.

It depends on where you're moving the emails to/from. For example, moving them from SPAM -> INBOX, the UIDS are all populated in the UidPlusResult, but moving them back from INBOX -> SPAM, the UID objects are NULL. This is consistent and reproducable.

In all cases, "IsSupported" is true on the UidPlusResult, so I would expect the UID collections to be instantiated and correct.

Do you have any ideas on why I'm seeing this behaviour?

Many thanks,

Hedley
Back to Top View hmuscroft's Profile Search for other posts by hmuscroft
 
Alex
AfterLogic Support
AfterLogic Support
Avatar

Joined: 19 November 2003
Online Status: Offline
Posts: 2159
Posted: 28 January 2017 at 7:36am | IP Logged Quote Alex

Please try the newer build at http://www.afterlogic.com/updates/mailbee_net.zip

Does it make a difference?

Regards,
Alex
Back to Top View Alex's Profile Search for other posts by Alex
 
hmuscroft
Groupie
Groupie


Joined: 29 December 2009
Location: United Kingdom
Online Status: Offline
Posts: 72
Posted: 30 January 2017 at 4:53am | IP Logged Quote hmuscroft

Hi - referencing the latest DLL results in the program not compiling :-

The compiler comes back with :-

Could not load file or assembly 'file:///E:\vs\comps\_manual\MailBee.NET\MailBee.NET.dll' or one of its dependencies. Operation is not supported. (Exception from HRESULT: 0x80131515)

I tried upgrading my project to .NET 4.5 (it was 4.0 previously) and then referenced "MailBee.NET.45.dll" instead, and it now says :-

'file:///E:\vs\comps\_manual\MailBee.NET\MailBee.NET.45.dll' or one of its dependencies. Operation is not supported. (Exception from HRESULT: 0x80131515)     ClinicOffice     E:\vs\source\ClinicOffice\ClinicOffice\SGEN
Back to Top View hmuscroft's Profile Search for other posts by hmuscroft
 
Alex
AfterLogic Support
AfterLogic Support
Avatar

Joined: 19 November 2003
Online Status: Offline
Posts: 2159
Posted: 30 January 2017 at 5:02am | IP Logged Quote Alex

That's what Google says (SO, actually):

http://stackoverflow.com/questions/34400546/could-not-load-file-or-assembly-operation-is-not-supported-exception-from-hres

Regards,
Alex
Back to Top View Alex's Profile Search for other posts by Alex
 
hmuscroft
Groupie
Groupie


Joined: 29 December 2009
Location: United Kingdom
Online Status: Offline
Posts: 72
Posted: 30 January 2017 at 5:03am | IP Logged Quote hmuscroft

Is it possible that these still rely on "HtmlAgilityPack" or "iTextSharp" which wasn't included?
Back to Top View hmuscroft's Profile Search for other posts by hmuscroft
 
Igor
AfterLogic Support
AfterLogic Support


Joined: 24 June 2008
Location: United States
Online Status: Offline
Posts: 5750
Posted: 30 January 2017 at 5:07am | IP Logged Quote Igor

That shouldn't be a problem, the issue seems to be related to ZIP archive usage.

--
Regards,
Igor, AfterLogic Support
Back to Top View Igor's Profile Search for other posts by Igor
 
hmuscroft
Groupie
Groupie


Joined: 29 December 2009
Location: United Kingdom
Online Status: Offline
Posts: 72
Posted: 30 January 2017 at 5:08am | IP Logged Quote hmuscroft

You're correct - I had to RIGHT-CLICK on the DLLs and then go to PROPERTIES and select UNBLOCK to make it work.
Back to Top View hmuscroft's Profile Search for other posts by hmuscroft
 
hmuscroft
Groupie
Groupie


Joined: 29 December 2009
Location: United Kingdom
Online Status: Offline
Posts: 72
Posted: 31 January 2017 at 12:06am | IP Logged Quote hmuscroft

That update seems to have fixed the issue with UidPlusResult UIDCollections not being set - thanks.

I noticed that you have a MIN (MINimum?) version of the MailBee.NET DLLs in that release along with the full versions - may I ask what the difference is and how I know which I should use?

Also, was this a 'pre-release' version that you sent, or is it the latest release version which I can download and install from your website?

Many thanks!
Back to Top View hmuscroft's Profile Search for other posts by hmuscroft
 
Igor
AfterLogic Support
AfterLogic Support


Joined: 24 June 2008
Location: United States
Online Status: Offline
Posts: 5750
Posted: 31 January 2017 at 1:26am | IP Logged Quote Igor

DLLs which have .Min as a part of their names do not contain dependencies towards iTextSharp and HtmlAgilityPack assemblies. So if you're not using PDF Component, using .Min build would be a recommended option.

While DLLs found here are technically considered beta versions, those are tested prior to making them available for download, and usually they're substantially improved compared to DLL builds shipped in EXE/MSI packages.

--
Regards,
Igor, AfterLogic Support
Back to Top View Igor's Profile Search for other posts by Igor
 

If you wish to post a reply to this topic you must first login
If you are not already registered you must first register

  Post ReplyPost New Topic
Printable version Printable version

Forum Jump

Powered by Web Wiz Forums version 7.9
Copyright ©2001-2004 Web Wiz Guide