Search The ForumSearch   RegisterRegister  LoginLogin

MailBee.NET IMAP

 AfterLogic Forum : MailBee.NET IMAP
Subject Topic: Unable to login IBM Verse using IMAP Post ReplyPost New Topic
Author
Message << Prev Topic | Next Topic >>
j.mayuresh24
Newbie
Newbie


Joined: 12 October 2016
Location: India
Online Status: Offline
Posts: 1
Posted: 12 October 2016 at 9:54pm | IP Logged Quote j.mayuresh24

Hi:

I am evaluating the Mailbee.Imap. I want to connect to IBM verse using IMAP connection and upload the messages. But the connection to IMAP server throwing exception. Here is my sample code

MailBee.ImapMail.Imapobjimap = new MailBee.ImapMail.Imap();
bjimap.Timeout = int.MaxValue;
objimap.Connect("imap.notes.na.collabserv.com"); //Not allow to connect throws exception

if (objimap.Login(username, pass))
   {}
else
   {}

Exception Log

"Socket connection has timed out. InnerException message follows: A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond 192.155...

If I try to conenect to Gmail using same method its working properly. Facing issue with IBM verse only. Please let me know what can be done to resolve this issue.

Thanks in advance:
Mayuresh
Back to Top View j.mayuresh24's Profile Search for other posts by j.mayuresh24
 
Alex
AfterLogic Support
AfterLogic Support
Avatar

Joined: 19 November 2003
Online Status: Offline
Posts: 2158
Posted: 13 October 2016 at 12:40am | IP Logged Quote Alex

It seems this server has SSL connection only. Try using

objimap.Connect("imap.notes.na.collabserv.com", 993)

Regards,
Alex
Back to Top View Alex's Profile Search for other posts by Alex
 
toledo.carolina
Newbie
Newbie


Joined: 23 November 2017
Location: Brazil
Online Status: Offline
Posts: 2
Posted: 23 November 2017 at 3:22pm | IP Logged Quote toledo.carolina

Were you able to ?

I'm trying in VBA using CDO and stmp . I tried using port 25 , 465 and 587 .

Sub send_emaill()

Dim myMail As CDO.Message
Set myMail = New CDO.Message

myMail.Configuration.Fields.Item("http://schemas.microsoft.com/cdo/configuration/smtpusessl") = True
myMail.Configuration.Fields.Item("http://schemas.microsoft.com/cdo/configuration/smtpauthenticate") = 1
myMail.Configuration.Fields.Item("http://schemas.microsoft.com/cdo/configuration/smtpserver") = "smtp.notes.na.collabserv.com"
myMail.Configuration.Fields.Item("http://schemas.microsoft.com/cdo/configuration/smtpserverport") = 25
myMail.Configuration.Fields.Item("http://schemas.microsoft.com/cdo/configuration/sendusing") = 2
myMail.Configuration.Fields.Item("http://schemas.microsoft.com/cdo/configuration/sendusername") = "myid@br.ibm.com"
myMail.Configuration.Fields.Item("http://schemas.microsoft.com/cdo/configuration/sendpassword") = "mypassword"
myMail.Configuration.Fields.Update

With myMail
.Subject = "Test SMTP"
.From = "myid@br.ibm.com"
.To = "other@br.ibm.com"
.BCC = ""
.TextBody = "Test SMTP"
'.AddAttachment "C:\Users\takyar\Desktop\email-via-gmail.txt"
End With
On Error Resume Next
myMail.Send
MsgBox ("Mail has been sent")
Set myMail = Nothing

End Sub
Back to Top View toledo.carolina's Profile Search for other posts by toledo.carolina
 
Igor
AfterLogic Support
AfterLogic Support


Joined: 24 June 2008
Location: United States
Online Status: Offline
Posts: 5722
Posted: 23 November 2017 at 11:02pm | IP Logged Quote Igor

toledo.carolina, I've answered this here.

--
Regards,
Igor, AfterLogic Support
Back to Top View Igor's Profile Search for other posts by Igor
 

If you wish to post a reply to this topic you must first login
If you are not already registered you must first register

  Post ReplyPost New Topic
Printable version Printable version

Forum Jump

Powered by Web Wiz Forums version 7.9
Copyright ©2001-2004 Web Wiz Guide