Search The ForumSearch   RegisterRegister  LoginLogin

MailBee IMAP4

 AfterLogic Forum : MailBee IMAP4
Subject Topic: Error When Downloading Email Post ReplyPost New Topic
Author
Message << Prev Topic | Next Topic >>
emagnusson
Newbie
Newbie


Joined: 09 July 2012
Online Status: Offline
Posts: 10
Posted: 09 July 2012 at 2:42pm | IP Logged Quote emagnusson

Microsoft VBScript runtime error '800a01fb'

An exception occurred: 'RetrieveSingleMessage'

Here's the log:

16:37:39 [MailBee IMAP4 v7.0.0.170. Registered version]
16:37:39 [Connecting to server mail.24-7clients.com at port 143]
16:37:39 [Using regular IMAP4 authentication]
16:37:39 [Sending UserName and Password]
16:37:39 [Authenticated]
16:37:39 [Sending command: MBC000002 SELECT "Inbox"\r\n]
16:37:39 [Mailbox selected]
16:37:39 [Sending command: MBC000003 FETCH 1 (RFC822.SIZE BODY[])\r\n]
16:37:39 [Message ready]
16:37:39 [Sending command: MBC000004 FETCH 2 (RFC822.SIZE BODY[])\r\n]
16:37:48 [Message ready]
16:37:53 [Sending command: MBC000005 FETCH 3 (RFC822.SIZE BODY[])\r\n]
Back to Top View emagnusson's Profile Search for other posts by emagnusson
 
emagnusson
Newbie
Newbie


Joined: 09 July 2012
Online Status: Offline
Posts: 10
Posted: 09 July 2012 at 2:48pm | IP Logged Quote emagnusson

I've also attempted this with POP3 with the exact same result. The log is slightly changed to reflect the different technology.
Back to Top View emagnusson's Profile Search for other posts by emagnusson
 
Igor
AfterLogic Support
AfterLogic Support


Joined: 24 June 2008
Location: United States
Online Status: Offline
Posts: 5595
Posted: 09 July 2012 at 10:17pm | IP Logged Quote Igor

Are you getting the same behavior with current v8 release? Also, does the issue occur if you get that particular message alone?

--
Regards,
Igor, AfterLogic Support
Back to Top View Igor's Profile Search for other posts by Igor
 
emagnusson
Newbie
Newbie


Joined: 09 July 2012
Online Status: Offline
Posts: 10
Posted: 10 July 2012 at 7:57am | IP Logged Quote emagnusson

Sorry, but could you tell me how to go about getting the v8 release?

As for your second question... sometimes. Other times it retrieves the message, but the "Subject" property returns blank.

Could it have something to do with the size of the file or email? The email is listed as 54525.92 kB in size, and the attachment is a 39844.97 kB PDF.
Back to Top View emagnusson's Profile Search for other posts by emagnusson
 
emagnusson
Newbie
Newbie


Joined: 09 July 2012
Online Status: Offline
Posts: 10
Posted: 10 July 2012 at 9:32am | IP Logged Quote emagnusson

Ok, we installed version 8 and ran our program with only the one file in the mailbox. Here is the log:

11:33:36 [MailBee POP3 v7.0.0.170. Registered version]
11:33:36 [Connecting to server mail.24-7clients.com at port 110]
11:33:36 [Using regular POP3 authentication]
11:33:36 [Sending UserName]
11:33:36 [Sending Password]
11:33:36 [Connected to the server, getting statistics]
11:33:36 [Got stat, 1 message(s) available. Total size is 55834516 bytes]
11:33:36 [Getting list]
11:33:36 [Got list]
11:33:36 [Sending retr/top command: RETR 1\r\n]
11:33:59 [Message data received, decoding the message]
11:33:59 [The message is ready]
11:33:59 [Disconnecting from the server]
11:33:59 [Connection closed]

Everything looks fine, but the Subject property is still returning an empty string.
Back to Top View emagnusson's Profile Search for other posts by emagnusson
 
Alex
AfterLogic Support
AfterLogic Support
Avatar

Joined: 19 November 2003
Online Status: Offline
Posts: 2150
Posted: 10 July 2012 at 9:44am | IP Logged Quote Alex

The log clearly shows you're using 7.0, not 8.0. Also, if you download the same message with another POP3 client (like Mozilla Thunderbird), does subject display fine?

Regards,
Alex
Back to Top View Alex's Profile Search for other posts by Alex
 
emagnusson
Newbie
Newbie


Joined: 09 July 2012
Online Status: Offline
Posts: 10
Posted: 10 July 2012 at 10:33am | IP Logged Quote emagnusson

Don't know what to tell you. Mailbee Objects version 7 was uninstalled and version 8 replaced it. However, there is one dll that isn't removed on uninstall and won't allow us to delete citing a sharing violation or that the source file is in use.

Message is downloaded and subject is displayed properly by Mozilla Thunderbird.
Back to Top View emagnusson's Profile Search for other posts by emagnusson
 
Igor
AfterLogic Support
AfterLogic Support


Joined: 24 June 2008
Location: United States
Online Status: Offline
Posts: 5595
Posted: 10 July 2012 at 10:59am | IP Logged Quote Igor

Sounds like the DLL is used by some other application, maybe IIS. Instructions on upgrading the product version are found here. Prior to installing the new version, existing one must be removed completely.

--
Regards,
Igor, AfterLogic Support
Back to Top View Igor's Profile Search for other posts by Igor
 
emagnusson
Newbie
Newbie


Joined: 09 July 2012
Online Status: Offline
Posts: 10
Posted: 10 July 2012 at 11:38am | IP Logged Quote emagnusson

Ok, we managed to get the new version installed and now our license key doesn't work?
Back to Top View emagnusson's Profile Search for other posts by emagnusson
 
Igor
AfterLogic Support
AfterLogic Support


Joined: 24 June 2008
Location: United States
Online Status: Offline
Posts: 5595
Posted: 10 July 2012 at 11:41am | IP Logged Quote Igor

MBC800 key is required for v8. If you don't have one, you can request it via our helpdesk, but first make sure your maintenance contract is valid.

--
Regards,
Igor, AfterLogic Support
Back to Top View Igor's Profile Search for other posts by Igor
 
emagnusson
Newbie
Newbie


Joined: 09 July 2012
Online Status: Offline
Posts: 10
Posted: 20 July 2012 at 2:16pm | IP Logged Quote emagnusson

Had to step away from this project to work on a few other things but I'm back to it now and having issues again.

One of the files will not download from the mailbox. After this line in the code:
Set objMsg = objIMAP4.RetrieveSingleMessage(i,false)

...the IsError property is set and returns a blank ErrDesc and an ErrCode of 8.

Here is the log:

16:09:20 [MailBee IMAP4 v8.0.0.172. Registered version]
16:09:20 [Connecting to server mail.24-7clients.com at port 143]
16:09:20 [Using regular IMAP4 authentication]
16:09:20 [Sending UserName and Password]
16:09:20 [Authenticated]
16:09:20 [Sending command: MBC000002 SELECT "Inbox"\r\n]
16:09:20 [Mailbox selected]
16:09:20 [Sending command: MBC000003 FETCH 1 (RFC822.SIZE BODY[])\r\n]
16:09:20 [Message ready]
16:09:20 [Sending command: MBC000004 FETCH 2 (RFC822.SIZE BODY[])\r\n]
16:09:32 [Message ready]
16:09:38 [Sending command: MBC000005 FETCH 3 (RFC822.SIZE BODY[])\r\n]
16:09:38 [Connection closed due to network error or timeout.]
16:09:38 [Error: Not connected]
16:09:38 [Error: Not connected]
Back to Top View emagnusson's Profile Search for other posts by emagnusson
 
emagnusson
Newbie
Newbie


Joined: 09 July 2012
Online Status: Offline
Posts: 10
Posted: 20 July 2012 at 2:18pm | IP Logged Quote emagnusson

And as you can tell from the log, we have upgraded to version 8.
Back to Top View emagnusson's Profile Search for other posts by emagnusson
 
Alex
AfterLogic Support
AfterLogic Support
Avatar

Joined: 19 November 2003
Online Status: Offline
Posts: 2150
Posted: 21 July 2012 at 3:54am | IP Logged Quote Alex

Thanks. We'll need access to this account and the problem email to identify this issue. If possible, please submit this info through our HelpDesk system.

Regards,
Alex
Back to Top View Alex's Profile Search for other posts by Alex
 
emagnusson
Newbie
Newbie


Joined: 09 July 2012
Online Status: Offline
Posts: 10
Posted: 26 July 2012 at 2:39pm | IP Logged Quote emagnusson

One other question before we go that route. Is there a known email size limit that is allowed per connection? I can download a half dozen emails with smaller attachment sizes, but not two with a larger one.
Back to Top View emagnusson's Profile Search for other posts by emagnusson
 
Igor
AfterLogic Support
AfterLogic Support


Joined: 24 June 2008
Location: United States
Online Status: Offline
Posts: 5595
Posted: 27 July 2012 at 12:31am | IP Logged Quote Igor

Quote:
Is there a known email size limit that is allowed per connection?


Not on MailBee side. There might be restrictions imposed by mail server or your system (like, amount of memory used).

--
Regards,
Igor, AfterLogic Support
Back to Top View Igor's Profile Search for other posts by Igor
 
emagnusson
Newbie
Newbie


Joined: 09 July 2012
Online Status: Offline
Posts: 10
Posted: 22 September 2012 at 11:28am | IP Logged Quote emagnusson

So this issue has started reappearing again. It seems to have to do with attachment file size. We attempted to "retrievesinglemessage" on an email with an attachment of 3000kb and received the error from my original post. We tried everything we could think of, renaming the file, renaming the email, resending the email, sending the email from another address... nothing changed. Got the same error message each time until we split the attachment into two 1500kb files and sent it in two parts. Then it downloaded and the remainder of the code worked flawlessly.

What could be causing this issue?
Back to Top View emagnusson's Profile Search for other posts by emagnusson
 

If you wish to post a reply to this topic you must first login
If you are not already registered you must first register

  Post ReplyPost New Topic
Printable version Printable version

Forum Jump

Powered by Web Wiz Forums version 7.9
Copyright ©2001-2004 Web Wiz Guide