Search The ForumSearch   RegisterRegister  LoginLogin

MailBee.NET POP3

 AfterLogic Forum : MailBee.NET POP3
Subject Topic: error on retrieve Post ReplyPost New Topic
Author
Message << Prev Topic | Next Topic >>
tiipe
Newbie
Newbie


Joined: 26 November 2009
Online Status: Offline
Posts: 1
Posted: 26 November 2009 at 12:47am | IP Logged Quote tiipe

I am having trouble getting the pop3 component work. It works when I do a QuickDownloadMessage, but when I try to download one or several messages using the Pop3-object it fails with the following log:

[10:06:44.36] [INFO] Assembly version: 5.8.2.173.
[10:06:44.35] [INFO] Will resolve host "***".
[10:06:44.37] [INFO] Host "***" resolved to IP address(es) **.**.**.**.
[10:06:44.38] [INFO] Will connect to host "**" on port 110.
[10:06:44.39] [INFO] Socket connected to IP address **.**.**.** on port 110.
[10:06:44.40] [RECV] +OK POP3 *** server ready\r\n
[10:06:44.41] [INFO] Connected to mail service at host "***" on port 110 and ready.
[10:06:45.00] [INFO] Get the list of advertized SASL authentication methods via AUTH command.
[10:06:45.01] [SEND] AUTH\r\n
[10:06:45.02] [RECV] +OK Supported authentication mechanisms:\r\n.\r\n
[10:06:45.03] [INFO] Will login as "***".
[10:06:45.04] [INFO] Will try regular USER/PASS authentication.
[10:06:45.05] [SEND] USER ***\r\n
[10:06:45.06] [RECV] +OK User name accepted, password please\r\n
[10:06:45.07] [SEND] PASS ********\r\n
[10:06:45.09] [RECV] +OK Mailbox open, 2 messages\r\n
[10:06:45.10] [INFO] Logged in as "***".
[10:06:45.11] [INFO] Download inbox statistics.
[10:06:45.12] [SEND] STAT\r\n
[10:06:45.12] [RECV] +OK 2 3410\r\n
[10:06:46.73] [INFO] Will download entire messages (startIndex=1, count=2).
[10:06:46.74] [SEND] RETR 1\r\n
[10:06:48.42] [INFO] Error: The socket object used by MailBee was unexpectedly closed. InnerException message follows: Unable to read data from the transport connection: A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond.
[10:06:48.43] [INFO] Will disconnect from host "***".
[10:06:48.44] [INFO] Disconnected from host "***".

Any idea what is going wrong?
Back to Top View tiipe's Profile Search for other posts by tiipe
 
Igor
AfterLogic Support
AfterLogic Support


Joined: 24 June 2008
Location: United States
Online Status: Offline
Posts: 5873
Posted: 26 November 2009 at 7:28am | IP Logged Quote Igor

Are you setting pop3 timeout in your code? If yes, make sure that timeout value is high enough. If not, please provide us with full error log.

--
Regards,
Igor, AfterLogic Support
Back to Top View Igor's Profile Search for other posts by Igor
 

If you wish to post a reply to this topic you must first login
If you are not already registered you must first register

  Post ReplyPost New Topic
Printable version Printable version

Forum Jump

Powered by Web Wiz Forums version 7.9
Copyright ©2001-2004 Web Wiz Guide