Search The ForumSearch   RegisterRegister  LoginLogin

MailBee.NET IMAP

 AfterLogic Forum : MailBee.NET IMAP
Subject Topic: IMAP4 in Gmail Post ReplyPost New Topic
Author
Message << Prev Topic | Next Topic >>
zorroc
Newbie
Newbie
Avatar

Joined: 15 May 2008
Location: Brazil
Online Status: Offline
Posts: 9
Posted: 09 June 2008 at 6:53am | IP Logged Quote zorroc

someone ever used the imap in gmail?

I turn on the imap in my e-mail account, gmail, and the page:
http://mail.google.com/support/bin/answer.py?answer=78799

I caught the address of the server and port, but when I try to connect through the component MailBee.ImapMail.Imap, an error message appears, it must be because gmail requires a secure connection (SSL), I did a test here and unable to connect, is my way:

imp.SslMode = Security.SslStartupMode.OnConnect
imp.SslProtocol = Security.SecurityProtocol.Ssl2
imp.Connect("imap.gmail.com", 993)

thanks.
Back to Top View zorroc's Profile Search for other posts by zorroc
 
Andrew
AfterLogic Support
AfterLogic Support


Joined: 28 April 2006
Location: United States
Online Status: Offline
Posts: 1189
Posted: 09 June 2008 at 7:19am | IP Logged Quote Andrew

Yes, this sample shows how to do this. If it doesn't work for you, please enable logging, reproduce the issue and provide us with the log file.

Best regards,
Andrew
Back to Top View Andrew's Profile Search for other posts by Andrew
 
zorroc
Newbie
Newbie
Avatar

Joined: 15 May 2008
Location: Brazil
Online Status: Offline
Posts: 9
Posted: 09 June 2008 at 8:14am | IP Logged Quote zorroc

Log:

[12:01:05.87] [INFO] Assembly version: 3.1.1.90.
[12:01:05.87] [INFO] Will resolve host "imap.gmail.com".
[12:01:05.92] [INFO] Host "imap.gmail.com" resolved to IP address(es) 66.249.83.109, 66.249.83.111.
[12:01:05.94] [INFO] Will connect to host "imap.gmail.com" on port 993.
[12:01:05.98] [INFO] Error: Socket connection has been refused by remote host. InnerException message follows: Nenhuma conexo pde ser feita porque a mquina de destino as recusou ativamente
Back to Top View zorroc's Profile Search for other posts by zorroc
 
Alex
AfterLogic Support
AfterLogic Support
Avatar

Joined: 19 November 2003
Online Status: Offline
Posts: 2182
Posted: 09 June 2008 at 8:32am | IP Logged Quote Alex

Does Outlook Express or Thunderbird successfully connect to imap.gmail.com when you run it on the same computer where you run MailBee?

Regards,
Alex
Back to Top View Alex's Profile Search for other posts by Alex
 
zorroc
Newbie
Newbie
Avatar

Joined: 15 May 2008
Location: Brazil
Online Status: Offline
Posts: 9
Posted: 09 June 2008 at 9:07am | IP Logged Quote zorroc

I tried to set up Outlook and did not connect too, must then be a problem with gmail.

thanks for your help.
Back to Top View zorroc's Profile Search for other posts by zorroc
 
Andrew
AfterLogic Support
AfterLogic Support


Joined: 28 April 2006
Location: United States
Online Status: Offline
Posts: 1189
Posted: 10 June 2008 at 12:02am | IP Logged Quote Andrew

Another possible reason is a firewall/antivirus software (installed on the workstation/server your application powered by MailBee.NET IMAP component is installed on) blocks secure IMAP connections. Try to temporarily disable it for testing purpose.

Best regards,
Andrew
Back to Top View Andrew's Profile Search for other posts by Andrew
 

If you wish to post a reply to this topic you must first login
If you are not already registered you must first register

  Post ReplyPost New Topic
Printable version Printable version

Forum Jump

Powered by Web Wiz Forums version 7.9
Copyright ©2001-2004 Web Wiz Guide